viernes, 11 de octubre de 2013

Seudocódigo y Java 7: Bucle Para ii

/*
* Seudocódigo que lea desde el teclado 10 números y que cuente e imprima cuántos de ellos son positivos.
*/
package seudocodigo7;
import java.util.Scanner;
/**
*
* @author Juan
*/

public class Seudocodigo7 {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
        int num, pos;
        Scanner entrada = new Scanner(System.in);
       
        /*
        para I de 1 a 100 hacer   -
             leer N
             si N >=0 entonces
                 C  C+1
              finsi  
        finpara
        escribir "Números positivos leidos: ", C
        */   
       
        pos =0;
        for (int i = 1; i <= 10; i++) {
            System.out.println("Introduzca un número");
            num= entrada.nextInt();
            if (num>=0) ++pos;
        }
       
        System.out.println("Números positivos: "+pos);
       
  }
}