lunes, 21 de octubre de 2013

Seudocódigo 11: Realizar un rectángulo de asteriscos de alto y largo variable


/*
* .- Pedir por teclado dos números A, B e imprimir un rectángulo formado por A asteriscos de largo y B asteriscos de alto (dejando espacios en blanco en el interior del rectángulo)
*/
package seudocodigo11;
import java.util.Scanner;
/**
*
* @author juan
*/
public class Seudocodigo11 {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
/*

* PROCEDIMIENTO principal
DECLARACIONES PRIVADAS
entero A,B,X,Y

CODIGO
leer A,B
para X de 1 a A hacer
   escribir "*"
finpara
avanzar línea
para X de 2 a B-1 hacer  
   escribir "*"
   para Y de 2 a A-1 hacer
       escribir " "
   fin para
   escribir "*"
   avanzar línea  
fin para
para X de 1 a A hacer
   escribir "*"
finpara
FIN PROCEDIMIENTO principal

*/
        Scanner entrada = new Scanner(System.in);
        int a,b,x,y;
   
        System.out.println("Introduzca el largo");
        a=entrada.nextInt();
        System.out.println("Introduzca el alto");
        b=entrada.nextInt();
        //Imprime la primera línea de asteriscos
        for (x = 1; x <= a; x++) {
            System.out.print("*");
        }
        //saltamos línea
        System.out.println();
       
       
        for (x = 2; x < b; x++) {
            System.out.print("*");
            for (y = 2; y < a; y++) {
                System.out.print(" ");               
            }
            System.out.print("*");
            System.out.println();
        }
         //Imprime la última línea de asteriscos
        for (x = 1; x <= a; x++) {
            System.out.print("*");
        }
        System.out.println();
    }
}