viernes, 11 de octubre de 2013

Ejercicios Ordinogramas 8 (en Java)

/*
* Leer un caracter y decir si es vocal o no
*/
package ordinograma8;

import java.util.Scanner;

/**
*
* @author Juan
*/
public class Ordinograma8 {


   
    public static void main(String[] args) {
        String cadena;
        char letra;
        Scanner entrada = new Scanner(System.in);
       
        //ESCRIBIR "Introduzca una letra"
        System.out.println("Introduzca una letra");
        //LEER cadena
        cadena = entrada.next();
       
        //CONVERTIMOS cadena a mayúscula y asignamos a letra el primer carácter
        letra = cadena.toUpperCase().charAt(0);
       
        /*SI (letra == 'A')||(letra=='E')||(letra=='I')||(letra=='O')||(letra=='U')
         *  ESCRIBIR "la letra es una vocal"
         * sino
         *  ESCRIBIR "La letra es una consonante"
         *FIN_si
         */
        if ((letra == 'A')||(letra=='E')||(letra=='I')||(letra=='O')||(letra=='U')) {
            System.out.printf("La letra es una vocal: %c",letra);
        } else {
            System.out.printf("La letra es una consonante: %c",letra);
        }
   
    }
}