lunes, 14 de octubre de 2013

Seudocódigo 10: Cálculo de la serie

/*
* Pedir por teclado un número N, y a continuación calcular e imprimir el valor de la siguiente expresión:
(1/2)+(2/3)+.....+(N-1)/N

*/
package seudocódigo10;
import java.util.Scanner;

/**
*
* @author Juan
*/
public class Seudocódigo10 {


    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
    /*
     * ENTERO numero
     * REAL resultado
     *
     * REPETIR
     *  ESCRIBIR "Introduzca número"
     *  LEER numero
     * MIENTRAS (numero<=0)
     *
     * resultado=0
     * PARA i=2 HASTA numero (INCREMENTOS DE 1)
     *  resultado = resultado + (i-1)/i
     * FIN_PARA
     *
     * ESCRIBIR resultado
     *
     */
     int numero;
     double resultado=0;
     Scanner entrada = new Scanner(System.in);
    
     //LEER el número
        do {           
            System.out.println("Introduzca un número");
            numero = entrada.nextInt();
        } while (numero<=0);
       
        for (int i = 2; i <= numero; i++) {
            resultado = resultado + (double)(i-1)/i;
            if (i==numero)
                System.out.printf("%d/%d ",i-1,i);
               else
                System.out.printf("%d/%d + ",i-1,i);
        }
        System.out.printf(" = %.4f",resultado);
       
       
   
   
    }
}