miércoles, 9 de octubre de 2013

Explicación: Bucle While en java

/*
 * Leer 10 numeros y calcular suma con while
 * Mismo ejercicio de antes con otro tipo de bucle (podría no ejecutarse el código interno)
 */
package explicacionwhile;



import java.util.Scanner;

/**
 *
 * @author Juan
 */
public class ExplicacionWhile {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
            //ENTERO cont,suma,num;
        int cont,suma,num;
        Scanner entrada = new Scanner(System.in);
     
        /*
        cont=0;
        suma=0;
        */
        cont=0;
        suma=0;
        /*MIENTRAS (CONT < 10)
         *      ESCRIBIR "introduzca número"
         *      LEER num
         *      suma = suma + num
         *      cont = cont +1
         * FIN_MIENTRAS
         */
     
        while (cont<10 p="">
    {       System.out.println("Introduzca número: ");
            num = entrada.nextInt();
            suma = suma +num;
            cont= cont+1;
        }
        // ESCRIBIR SUMA
        System.out.println(suma);
    }
}